[Twisted-Python] Implementing STARTTLS in a protocol

Kevin Horn kevin.horn at gmail.com
Sat May 24 21:21:14 MDT 2008

On Sat, May 24, 2008 at 10:57 AM, Jean-Paul Calderone <exarkun at divmod.com>

> On Fri, 23 May 2008 17:31:39 -0500, Kevin Horn <kevin.horn at gmail.com>
> wrote:
>> On Fri, May 23, 2008 at 3:32 PM, Jean-Paul Calderone <exarkun at divmod.com>
>> wrote:
>> [snip]
> I tried with Ubuntu 7.10, Python 2.5.1, Twisted trunk at HEAD, OpenSSL
> 0.9.8e-5ubuntu3, pyOpenSSL 0.6-2.3ubuntu1.  I also tried with the
> Twisted 2.5 release branch.  I don't have pyOpenSSL 0.7 handy at the
> moment.  Maybe you could give 0.6 a try?  I can't think of any changes
> between those versions that might be causing this, but one never knows.
> Jean-Paul
>  Perhaps there is something wrong with my certificates?  I would expect
>> that
>> this would cause errors on the server end, though...
> Seems like the cert is probably fine, yea.  I'm attaching the one I tested
> with so you can give it a try, though.

OK, tested on Win2K, Python 2.4, Twisted 8.1.0, PyOpenSSL 0.7, OpenSSL

using your cert...TLS handshake succeeded.

using my cert...same error as before

so there definitely seems to be something wrong with my certificate files

What procedure and/or OpenSSL commands did you use to create yours?  Maybe
I'm doing something incorrectly when creating certs?

Nice to see my code working though...thanks for your help so far!

Kevin Horn
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/twisted-python/attachments/20080524/d17d1c46/attachment.html>

More information about the Twisted-Python mailing list